openSUSE Leap 42.1 sólo tendrá versión de 64 bits

La próxima versión estable de openSUSE, sólo será lanzada en versión de 64 bits.

Quizás haya equipos obsoletos que utilicen arquitecturas de 32 bits, por lo que en estos equipos si quieres usar openSUSE, tendrás que seguir utilizando la versión 13.2 o la versión Evergreen de soporte extendido, ya que la nueva Leap 42.1 no se lanzará versiones para estas arquitecturas obsoletas.

A raiz de una consulta en las listas de correo, donde un usuario buscaba información porque no encontraba un enlace para descargar la milestone de openSUSE Leap de 32 bits, el encargado del lanzamiento de openSUSE, Stephan Kulow, le contestó que no había intención de desarrollar una versión de openSUSE Leap para estas arquitecturas.

Podéis leer el correo en este enlace, con la consiguiente larga lista de respuestas, opiniones, etc…

Así que de manera oficial, openSUSE en el próximo lanzamiento, esperado para el 4 de noviembre, de openSUSE Leap sólo habrá disponibles ISO’s para PC’s de arquitecturas de 64 bits.

Las respuestas no se han hecho esperar, han sido muchas y de muchos tipos. Con opiniones a favor, y algunas en contra.

Se argumenta que ese hardware es muy antiguo, y que son muy pocos los usuarios que todavía disponen de él y trabajan con él a diario. Para ellos, la opción es seguir con openSUSE 13.2 o con la versión Evergreen de soporte extendido.

Pero parece ser que de manera oficial no hay planes para desarrollar todo para arquitecturas de 32 bits. Hay algunas otras distribuciones las que hace tiempo sólo sacan ISO’s para arquitecturas de 64 bits. openSUSE se suma así a la tendencia actual, aunque sigue manteniendo el soporte con las versiones anteriores, y el software de los repositorios sigue disponible para estas arquitecturas.

¿Qué te parece? ¿debería seguir habiendo opción de versiones de 32 bits? o crees que es un trabajo muy grande para la poca demanda que tiene. Sin embargo opciones hay…

42

————————————————————

19 pensamientos en “openSUSE Leap 42.1 sólo tendrá versión de 64 bits

  1. Al igual que con KaOS, se pierde un usuario que le gusta hacer pruebas en maquinas físicas y lamentablemente 32 bits es la arquitectura que posee mi Laptop Gateway del 2006, que siempre uso para estos menesteres, de cierta manera lo veo como algo que va en contra de que con GNU/Linux no hay Hardware viejo, …claro siempre hay otras distros que probar, pero soy adicto al Lagarto. …so sad!!! :(..

    • Si, eso mencionaban algunos en el hilo de la lista de correo que he dejado en el enlace.
      Que un punto a favor de GNU/Linux es que no fuerza a sus usuarios a renovar sus máquinas… Eso es cierto, pero también lo es que segun parece no son muchos los usuarios de este tipo de arquitecturas, y por tanto los pocos recursos de los que se disponen hay que enfocarlos en la mayoría.
      Pero esto es código abierto, y si hay voluntarios y ganas, pueden hacer una versión… o usar las anteriores, o usar otra distro!! 😉
      Saludos.

  2. Hola.

    “Quizás haya equipos obsoletos que utilicen arquitecturas de 32 bits, por lo que en estos equipos si quieres usar openSUSE, tendrás que seguir utilizando la versión 13.2 o la versión Evergreen de soporte extendido, ya que la nueva Leap 42.1 no se lanzará versiones para estas arquitecturas obsoletas.”

    ¡O Tumbleweed! Aunque en el hilo que citas ya ha dejado alguno caer que no tiene claro por qué sigue teniendo soporte. No te extrañe que en un futuro no muy lejano lo eliminen también…

    Un saludo.

    • Hombre cuanto bueno por aqui!! 😉
      Cierto, quizás terminarán eliminando esa opción en Tumbleweed, depende de las ganas y recursos (desarrolladores) que haya para seguir adelante.
      Saludos!

  3. Bueno yo en cierto modo lo veo razonable, siempre y cuando haya otras versiones que se adapten a la máquina de uno o, incluso que, se pueda cambiar por otra distribución.Es el precio a pagar por las nuevas tecnologías. Lo que no me parecería bien es que por que uno tenga una máquina todavía en uso, tenga que abandonarla por otra mas moderna por exigencias del sistema de producción en nuestro Hemisferio Occidental: Producir, producir y producir a costa de lo que sea. Ya se sabe que la crisis…

    • Producir, comprar, tirar… y así nos va.
      Bueno, supongo que habrá mucho hardware de gente de 32bits que no quiere tirar, muy lícito. Siempre se pueden usar otras opciones, eso es lo bueno!! 😉

  4. Ya es hora de matar a los 32 bits, aunque tengamos máquinas de 32 bits y no nos guste (yo mismo tengo una vieja Lap que no puede con los 64 bits aunque es compatible)

    Demasiado lastre llevamos arrastrando con los 32 bits, los 64 bits ya llevan mas de 10 años con nosotros.

    Esto se llama evolución. Lo mismo pasaría cuando dieron el salto de los 16 a los 32 bits, no queda otra.

    Me parece una excelente idea la de openSUSE. Cuando todas las grandes hagan lo mismo, se acabó lo que se daba para lo viejuno.

    • Bueno, la cosa es que hay muuuuchos tipos de usuarios. Los que tienen sus propios servidores y no quieren renovarlos, los que tienen PC’s que necesitan y son “viejunos” etc…
      En el hilo de la lista de correo te das cuenta que existen muchas opciones, no se puede contentar a todos. Por tanto hay que centrarse en lo más demandado, pero de momento sigue habiendo opciones para todos los gustos.

      • NO, para nada. Hoy en día linux soporte más de 10 arquitecturas distintas, entre ellas 32 bits, ese soporte tiene que seguir. Si OpenSUSE sólo quiere trabajar sobre AMD o Intel bueno, pero distribuciones como Debian u OpenSUSE que trabajan sobre varias arquitecturas deberían continuar soportándolo.

  5. Es una evolución natural, si por un lado pedimos que las nuevas versiones incluyan novedades y nuevos recursos, no podemos pedir que sigan siendo compatibles con todos los sistemas.
    Si continúan dando soporte a versiones antiguas que soportan 32 bits, esa creo que es la forma de mantener la compatibilidad.

  6. ¿Y los programas que sólo existen para arquitectura de 32 bits, como por ejemplo Steam, o Skype? ¿habrá que hacer algún “apaño” de compatibilidad?

  7. Tan obsoletas, no.
    Creo que mas bien potencian el sistema para plataformas de intel y amd (vamos equipos de sobremesa, portátiles y servidores) ; dejando fuera otras plataformas como arm y equipos embebidos (y no se si también los power pc o micros de la serie 68000, aunque estos ya sean de 64bit ) .

    32bit no está obsoleto, hay micros de última generación para arm en 32bit , pero el sistema implica por ejemplo utilizar risc o instrucciones reducidas (lo que le puede convertir en un equipo bastante potente, eso si trabajando en otra plataforma) .

    Bien ese sistema en 32bit, puede correr en un equipo embebido, como pueda ser una analizador de gama alta, o equipos de medida y de laboratorio, no tienen necesidad de ejecutar todas las aplicaciones que vienen con el sistema, si no las adecuadas para cumplir sus objetivos (ejemplo de que se pueda usar como un media center o como programa de aplicaciones de en tv y un largo etc) .

    Eso si al no dedicarse a 32bit (y si fuese el caso de que usaran un solo entorno gráfico) , el sistema tendría mucha mas dedicación y se potenciaría mas (lo contrario que estar trabajando para distintos tipos de entornos, con múltiples librerías, etc ) .

    De luego se evitan mucho trabajo extra y quizás el producto final, sea uno de los mejores.

    Creo que es un sistema para los usuarios y empresas que pienso que pueda ser la mayoría

    Saludos cordiales

  8. Perdón por responder 2 veces, pero los sistemas operativos de 64bit, pueden ejecutar programas de 32bit para abajo. eso es bien sabido que solo hay que añadir las librerías adecuadas para entorno de 32bit, tal como viene sucediendo en las actuales versiones de 64bit.
    Mis equipos trabajan todos en 64bit, pero los drivers de algunas impresoras o aplicaciones las estoy ejecutando en 32bit sin problema.

    Excepto que excluyan el ejecutar el 32bit desde patrones de software de yast (run time 32, etc) .

    Saludos cordiales

Me gustaría saber tu opinión. Deja un comentario (Puedes usar MarkDown)

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s