openSUSE Tumbleweed revisión semanas 3 y 4 de 2017

openSUSE Tumbleweed es una distribución “Rolling Release” en desarrollo continuo. Aquí puedes estar al tanto de las últimas novedades.

Tumbleweed

Antes del fin de semana de nuevo puedes leer una nueva revisión de lo que ha acontecido estas semanas pasadas en openSUSE Tumbleweed la versión “rolling release” o de actualización continua de la distribución de GNU/Linux openSUSE.

El anuncio original lo puedes leer en el blog de Dominique Leuenberger, en este enlace:

Las ISO’s son instalables, pero si ya estás disfrutando de openSUSE Tumbleweed en tu equipo, simplemente deberás actualizarlo mediante “zypper up” o este otro comando que recomiendan en las listas de correo, para disfrutar de esas actualizaciones.

Como la semana pasada no hubo artículo de revisión semanal, en esta ocasión haremos un repaso de las semanas 3 y 4, que traen un montón de actualizaciones.

La revisión abarca las “snapshots” 0112, 0117, 0118, 0120, 0121, 0123, 0124 y 0125. Lo que hacen un total de 8 snapshots. Que entre otras muchas cosas contenían lo siguiente:

  • Una actualización de dbus que causó algún contratiempo.
  • Pulseaudio 10.0
  • Flatpak 0.8
  • Linux kernel 4.9.5
  • X.Org server 1.19.1
  • KDE Applications 16.12.1
  • qemu 2.7
  • llvm 3.9
  • Wine 2.0

Hubo algún problema con la actualización de dbus que causó que mientras se actualizaba el paquete dbus-1, el sistema reseteara el servidor de las X y la sesión se cerrara.

La razón es claramente un bug en el empaquetado: siempre que un paquete contiene un servicio que está siendo actualizado, los servicios son automáticamente reiniciados.

Para la mayoría de los casos esto es la acción apropiada. Para dbus (y algunos pocos más como servicios de bajo nivel) esto causa problemas del tipo que han ocurrido las pasadas semanas a algunos usuarios.

Hay muchas maneras de influir en este comportamiento: el usuario/administrador puede cambiar el comportamiento por defecto para su equipo en /etc/sysconfig/services y el empaquetador puede marcar su propio servicio como no reiniciable durante la actualización del paquete.

La falta de la segunda opción fue la causante del problema. Una nueva versión que soluciona esto se publicará pronto.

Y además también encontrarás:

  • systemd 232 – cada vez queda menos para que este disponible
  • Nuevo Linux Kernel – 4.9.6 o más actual
  • Libreoffice 5.3
  • KDE Frameworks 5.30 junto con Plasma 5.9
  • GStreamer 0.10 eliminación programada para el 3 de febrero de 2017

La eliminación de GStreamer 0.10 ha sido anunciada desde hace mucho tiempo y con la excepción de algunos paquetes, todo el mundo ha hecho lo mejor que sabe para eliminar este código ya no mantenido y obsoleto. Junto con él también wxWidgets 2.8 será eliminado. wxWidgets 3.0 ya está en Tumbleweed desde hace mucho tiempo.

Si quieres estar a la última con software actualizado y probado utiliza openSUSE Tumbleweed la opción rolling release de la distribución de GNU/Linux openSUSE.

Mantente actualizado y ya sabes: Have a lot of fun!!

Enlaces de interés

Geeko_ascii

——————————–

4 pensamientos en “openSUSE Tumbleweed revisión semanas 3 y 4 de 2017

  1. Hola:
    ¿Qué sustituye a gstreamer? yo creía que todos los gstreamer eran los diversos codecs de audio y vídeo.
    Saludos.

    • Hola; gstreamer 0.10 es obsoleto y no mantenido desde hace tiempo; su lugar es tomado por gstreamer 1.0 o superior. No debería haber complicaciones en tumbleweed si usas solo los repositorios oficiales; en cambio si tienes programas instalados desde otras fuentes solo resta esperar a que lo quiten y ver que pasa 🙂
      Saludos

Me gustaría saber tu opinión. Deja un comentario (Puedes usar MarkDown)

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s